安装Appnode出现Error: Package: 1:enchant-1.6.0-8.el7.x86_64 (os)

最近在全新VPS上安装Appnode和php76,php80时出现错误,无法安装环境,与CentOS版本号无关。

错误如下

--> Finished Dependency Resolution
Error: Package: 1:enchant-1.6.0-8.el7.x86_64 (os)
           Requires: libhunspell-1.3.so.0()(64bit)
           Removing: hunspell-1.3.2-15.el7.x86_64 (@anaconda)
               libhunspell-1.3.so.0()(64bit)
           Updated By: hunspell-1.7.0-7.el7.x86_64 (appnode)
              ~libhunspell-1.7.so.0()(64bit)
           Available: hunspell-1.3.2-16.el7.x86_64 (os)
               libhunspell-1.3.so.0()(64bit)
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
2:postfix-2.10.1-9.el7.x86_64 has missing requires of libmysqlclient.so.18()(64bit)
2:postfix-2.10.1-9.el7.x86_64 has missing requires of libmysqlclient.so.18(libmysqlclient_18)(64bit)
rdma-core-devel-51mlnx1-1.51066.x86_64 has missing requires of ibacm(x86-64) = ('0', '51mlnx1', '1.51066')
ERROR: install environment softwares failed: exit status 1

由于PHP8.0的enchant扩展(默认安装)依赖enchant2,会与PHP5/7的enchant扩展依赖的enchant1安装包冲突,因此暂时不支持PHP8与PHP5/7的enchant扩展并存。

如果用不到已安装的PHP5/7的enchant扩展,可将其卸载后再安装PHP8,也可不安装PHP8的enchant扩展。

https://bbs.appnode.com/thread-2542.htm

在安装时不必勾选php80,先安装php76或以下版本,后在安装php80时取消安装enchant扩展,即可解决问题。

本文作者 : 呆憨 小咸鱼
本文采用 CC BY-NC-SA 4.0 许可协议。转载和引用时请注意遵守协议、注明出处!
本文链接 : https://blog.daihan.top/install-appnode-error-package.html

评论

  1. efg3
    Windows Chrome 78.0.3904.108
    4天前
    2021-4-16 10:10:29

    礼品代发、一件代发快递就发www.danhw.com

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇